Jeff4
Posts: 19
Joined: Thu May 30, 2019 7:49 am
Location: Minneapolis, MN

Climate preconditioning stopped working and other oddities

I recently programmed preconditioning to preheat my 2019 e-Golf during a cold snap. While the car charges by the time requested, the pre-heating is not being performed. Any ideas?

P.S. This morning I deleted the charging profile with the preconditioning and added a new one. I will see if it works tomorrow.

P.P.S. In addition to the above problem, occasionally the car turns itself on after I shut down and disconnect my iPhone. It appears as if the CarPlay disconnect triggers a "turn on" command. I then have to push the on/off button again to shut down. Is there a way to restart the car control software?
f1geek
Posts: 1001
Joined: Fri Jan 23, 2015 1:18 pm
Location: SF Bay Area

Re: Climate preconditioning stopped working and other oddities

What is the power rating of your EVSE (in kW)?

Is your e-Golf an SE or a SEL?

What time did you set the departure for?

What time did you check to see if the car was warm?

When you say the the car "turns itself on after I shut down", how do you shut down the car and how do you know the car turned itself on (describe what you see)?
2017 e-Golf LE, Multi Coat White with Black Vegan Leather interior, purchased in early 2018
2015 e-Golf SEL leased for three years, returned in early 2018
Jeff4
Posts: 19
Joined: Thu May 30, 2019 7:49 am
Location: Minneapolis, MN

Re: Climate preconditioning stopped working and other oddities

Thanks a lot, Mr. f1geek, for replying to this and other posts. You're a real asset to the community!
What is the power rating of your EVSE (in kW)?
I have a JuiceBox 40 (in theory it could go to 9.6 kW) and have set my car to take as much as possible, so it is charging at 7.2 kW.
Is your e-Golf an SE or a SEL?
SEL
What time did you set the departure for?
Departure time was set at 9:00am.
What time did you check to see if the car was warm?
I got into the car at 9:00am, and it was stone cold (4 F this morning)! No evidence that ANY heating had occurred.
When you say the the car "turns itself on after I shut down", how do you shut down the car and how do you know the car turned itself on (describe what you see)?
This has happened 2 or 3 times. I put the car into park. I press the parking brake on (usually, perhaps sometimes after pushing on-off button). I shut down the car by pushing the on-off button (my foot is on the brake). I reach down, disconnect my iPhone (CarPlay is still displaying on screen), and bing! bing! the car powers up with the VW welcome screen. I scratch my head, push the on-off button again, and it shuts down.
f1geek
Posts: 1001
Joined: Fri Jan 23, 2015 1:18 pm
Location: SF Bay Area

Re: Climate preconditioning stopped working and other oddities

I try!

Ok. so it seems you have plenty of power (want at least 5 kW to ensure PTC can work).

I have noticed that when I use pre-conditioning, the car finished charging about 30 minutes before the departure time, then the EVSE turns off. Depending on how cold it is outside, the EVSE comes on (and the car heats) anywhere from ~25 minutes to 15 minutes before the departure time. But, I don't live in MN, so I suspect in your case the heating should come on at least 30 minutes before departure, if not earlier.

You could try resetting the infotainment system: turn on the car and then hold down the volume knob/power button for about 10 seconds to reboot the system. I have to do this about once a month because I look a the e-Manager and none of my settings are there. Rebooting the infotainment always solves this issue.

Just to be sure, you are pressing the "Engine Start/Stop" button, right? What happens if you don't have your phone connected?
2017 e-Golf LE, Multi Coat White with Black Vegan Leather interior, purchased in early 2018
2015 e-Golf SEL leased for three years, returned in early 2018
Jeff4
Posts: 19
Joined: Thu May 30, 2019 7:49 am
Location: Minneapolis, MN

Re: Climate preconditioning stopped working and other oddities

Just to be sure, you are pressing the "Engine Start/Stop" button, right? What happens if you don't have your phone connected?
Yes, I guess it does say "Start-Engine-Stop," rather than on-off. This has only happened when I hit that button while the phone is still connected, then disconnected while the car is powering down. It has never happened when I disconnect the phone before pressing "Start-Engine-Stop." Perhaps, too, it does not happen if I wait for the system to fully cycle to off. I may play around with some tests and will report back if anything becomes more clear.

I can accept a few software glitches here and there, but this was weird. I wasn't expecting the infotainment system to override the car control software.
f1geek
Posts: 1001
Joined: Fri Jan 23, 2015 1:18 pm
Location: SF Bay Area

Re: Climate preconditioning stopped working and other oddities

I agree this is very strange behavior. I use Carplay with my iPhone and never had the car turn on after I shut it down. You should take a video so if you decide to bring it into the dealer, you have proof, and I believe your car is probably still fully covered by the warranty.

As for the preconditioning, if you have time of use /off peak electricity set up in the e-Manager, you may want to turn that off and keep just the basic departure settings for charging and climate. Also, you may want to uncheck the option to warm the car using the battery only (though I'm not sure this matters).
2017 e-Golf LE, Multi Coat White with Black Vegan Leather interior, purchased in early 2018
2015 e-Golf SEL leased for three years, returned in early 2018
Jeff4
Posts: 19
Joined: Thu May 30, 2019 7:49 am
Location: Minneapolis, MN

Re: Climate preconditioning stopped working and other oddities

I agree this is very strange behavior. I use Carplay with my iPhone and never had the car turn on after I shut it down. You should take a video so if you decide to bring it into the dealer, you have proof, and I believe your car is probably still fully covered by the warranty.
Very good idea! Thanks!
Jeff4
Posts: 19
Joined: Thu May 30, 2019 7:49 am
Location: Minneapolis, MN

Re: Climate preconditioning stopped working and other oddities

Report: I deleted all locations and set up new ones, with departure times and climate settings. Things worked this time! Ah bugs, bugs, VW bugs...
f1geek
Posts: 1001
Joined: Fri Jan 23, 2015 1:18 pm
Location: SF Bay Area

Re: Climate preconditioning stopped working and other oddities

Great to hear it is working! VW software is a weak spot in the ID.4, as well, from what I’ve read. At least the ID.4 will get OTA updates.
2017 e-Golf LE, Multi Coat White with Black Vegan Leather interior, purchased in early 2018
2015 e-Golf SEL leased for three years, returned in early 2018

Return to “General / Main e-Golf Owners Forum”