E golf wont start thinks charge plug is still connected

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Moredian

***
Joined
Sep 21, 2022
Messages
1
Dear members,



I have some problems with mine e golf it wont start anymore because the car thinks the charge plug is still connected but it isnt.



I have readed out with obdeleven and got an static error in the BD module P33E100 it states electric error charge socket A I cant find anything about this error even in Erwin.


I also got a intermiddent error in the C6 module saying P31EA00 what means charge module faulty.


I testen the actuator of the charge plug locking mechanism with obdeleven and it works.


The led indicator permantly leds orange i checken online I found at that it maybe is the bd module fried due water so I replaced it with a second hand and still nothing.


If I disconnect the module the error goes away but still cant start.


Anyone else seen this?

It is an 2017 facelift e golf 7.5
 
My 2015 does the same thing. I have found that if you wait 60 seconds after unplugging the connector, then it clears and no longer thinks the charge plug is present. Did you ever figure out the cause? It is an annoying problem that I would like to stop.
 
When my egolf things the connector is still connected I go out to the socket and use my key to push that little silver pin above teh socket it
and then the egolf realizes the socket is no longer connect. i've heard some oil that pin to fix it. i've tried.. it seems to help.. but it still happens sometimes. maybe i'll hit it with oil again.
 
What is the bd module?
It is the battery charger control unit, that links to the socket sensors and actuators. (nothing high current as you can see from the wires)

Like Moredian I've had the same problem with water ingress due to it's questionable location next to the tail lights / vent.

1705742913532.png1705742989372.png

1705743258125.png1705743231195.png
After cleaning up the PCB, all the v+ pins on the bottom side of the processor had corroded away, so the unit needed to be replaced.


However I'm still getting a P33E100 error. (Which is what lead me to this thread)



I'm not sure this particular unit was fitted to all versions, as some wiring diagrams show these signal lines going direct to the charger at the front?


For reference, the lock pin actuator looks like this.
https://www.farnell.com/datasheets/2911019.pdf (The wire colours tie up those at the ecu)
So after disconnecting the BD unit, 12v for a split second across the motor pin wires releases the locking pin.



Needless to say, when I get it working again, I'll be doing something to stop it filling up again ( even if it is drilling a hole in the box to let the water out ! )
 
Last edited:
A bit more information that might be of use to others when fault finding...

https://www.digikey.co.uk/en/products/detail/phoenix-contact/1162148/13923338

1707651796444.png

These wires go to the ECU shown in my photo above on my UK 2019 e-golf. Earlier ones may go the the charger at the front.

1707652018850.png
1707653190699.png
( I think the motor is relocated due to space issues above the connector? )

So with the connector removed from the ECU, 12v (for a Maximum of 1 second) between the Blue/Green(T32a/15) and Blue/Yellow(T32a/31) will either lock or unlock, depending on the direction. (luckily no special de-pining tools are required to remove the pins from the connector, just a small jewellers screwdriver)

This in turn should change the resistance between Blue/Red(T32a/16) and Blue/Brown (T32a/32) from 1k when unlocked, to 11k when locked.

1707654008390.png
All 4 wires can are on one end of the connector.
 
Last edited:
You might want to try turning the car off, then on, then off again..
and hitting the unlock button.

That worked for me once. I keep a screw driver in the rear passenger door pocket for the times
the plug doesn't want to unlock and have to hit that silver rod/button thing mentioned above..
and sometimes i need it for this situation too. I need to put some silicon spray in my car for the next time the button thingee is stuck out so that it will be lubed when it goes back in.
 

Latest posts

Back
Top