CarPlay no longer working

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.
Nov 2, 2015
Santa Cruz, CA
So yesterday CarPlay stopped working. I plug in the phone and it recognizes a USB device; likewise the phone recognizes something on the other end, but the CarPlay menu never pops up. Tried swapping the cable and checking connections, same behavior.

My main phone is an iPhone 6 with iOS 9.3.5. Last software upgrade was mid last week. Just for giggles I plugged in a iPad mini 3 with 9.3.2 and got the same result. Also tried a Sony Android 5.1.1 phone and saw similar behavior - phone recognized a computer on the other side, but the infotainment system doesn't seem to recognize the phone.

Anyone seen this?
i'd check VWvortex website for 2016 and MkVII golf problems, to see if anyone else is having the same problems with the same infotainment center, if it's shared among MVII golfs.
Couldn't find much there. The best suggestion was do a 'soft reboot', where you stop the car, lock it, and leave it for about 20 minutes. The essentially puts the infotainment system in sleep mode. However I tried that twice and still no luck.
Well this turned out to be a simple fix. After poking around in the Menu, it indicated the iPhone was detected as a valid device, but not fully selected.

Menu -> App-Connect -> Setup (in lower right corner) -> Select Device

Tapped my iPhone and poof, CarPlay started working again.