Locking charger plug. YA way to loose...

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Jan 7, 2015
Boston suburb
Sue left for work this morning. A few minutes later I get a call, "The car hates me". I throw on my cold weather gear, and go look. (for all of you in CA, there were a whole 10 Fahrenheit's present this morning, and a mere 5 in evidence right now, no, I don't hear your gloating)

She couldn't get the charger plug to unlock. It had finished charging, but wasn't letting go. I tried hitting the unlock on my fob, no sound of the door solenoids. Hit lock, again no clack... Open door, discover car status: ready, she had started it before removing the plug, so she could give the defroster a head start on the windshield. She then stepped out of the car, fob still clipped to her belt loop.

Discover you can't unlock the charge plug after you hit Start and get out of the car!

Hit start to shut things down, double click my fob, and it finally lets go of its umbilicus. I could be convinced that it might ignore a request to lock if the car is "running", but unlock should be heeded no matter what the status.

Of particular annoyance for me: I have set the central locking preference to "unlock all", so touching the drivers door, or single clicking the fob and all doors unlock (including the charger door if it is closed). The charger port is special it seems, only a double tap on the fob will let you actually disconnect, and you apparently have to do it before starting things...

Someone mentioned getting some sort of firmware update, and it had as a side effect a change in behavior so that the car would auto unlock the charger plug when it's full. It wasn't the car net update, but may have been part of the heat/ac update. Don't know if it required a module change (Someone said that just happened with their car, don't know what it was fixing) or if it was just a download from the dealer diagnostic port..
So a double click works? After ten minutes of fumbling around I finally tried unlocking at the door switch and that worked. Again the locking charger as default setting is just going out of your way to irritate drivers.